Problem
You set up SSO with your Gtmhub account. Some users can log in just fine, while others are getting the following error message:
Cause
This error can happen only if you have federated more than one domain in your Identity Provider. For example, you have users with both digital.com and inc.com domains in your Azure AD. When you set up SSO with Gtmhub, you specify what is your primary Identity provider tenant domain. Let's say this is digital.com. So anyone that has @digital.com email will log in to Gtmhub OK. But your users who have @inc.com email domain will experience the above error, as you did not configure Gtmhub to accept this domain as well, as part of the SSO configuration.
Solution
You must send an email to support@gtmhub.com and request the Gtmhub Technical Support team to add the missing domains. In your request list all the email domains you're federating in your Identity Provider, that you'd like us to configure for you.