Problem
I can see the insights in my Gtmhub account, but I'm unable to edit or delete them. I cannot create new insights as well.
Cause
To create, edit or delete an Insight, your Gtmhub user must have the Data or Admin roles assigned
Solution
Assign the Data or the Admin role to a user, following these steps:
Navigate to settings;
Users > choose a user
Assign the Data or the admin role

Additional information
The Data and Admin predefined roles include the Manage Data action, and this enables users assigned to these roles to create, edit and delete Insights.
Alternatively, you can create a new role that includes the Manage Data action ....
Navigate to settings;
Users > Manage roles > Add new role >
Provide a name the new role
Assign actions to the new role including the "ManageData" action
SAVE